Resharper 5.0 Beta support?

Topics: ReSharper test runner
Dec 28, 2009 at 11:48 PM

Any chance of getting a build that works with the Resharper 5.0 Beta that was recently released?  

Coordinator
Dec 30, 2009 at 11:45 AM

oh-oh. Didn't realise that things had broken in the beta. Might have known, since they released the beta just before holiday time! (And just when I've taken the opportunity to rebuild my dev machine...) I'll get a new build sorted in the next day or so.

Cheers
Matt

Dec 30, 2009 at 1:30 PM

thanks!  yeah...I think the beta was a holiday present. =)

Coordinator
Jan 3, 2010 at 6:35 PM

Done! Fortunately, a nice simple change...

Jan 4, 2010 at 12:20 AM

just tried it out and i'm getting this error message when I load up VS2010:

The plugin xunit could not be loaded from "C:\program files(x86)\jetBrains\resharper\v5.0\bin\plugins\xunit.dll" or one of its dependencies.  Operation is not supported.  (Exception from HRRESULT: 0x801311515)

any ideas how to fix this up?

Jan 7, 2010 at 1:28 PM

I'm seeing the same thing. Windows 7 64 bit; VS2010 Beta 2; ReSharper 5 Beta and the 1565 build of xUnit contrib. Tried in both Program Files(x86) and in Roaming,

 

Kevin

Coordinator
Jan 7, 2010 at 10:45 PM

Some basics first, I guess. The plugins folder needs the following files:

  1. xunitcontrib.runner.resharper.provider.5.0.dll
  2. xunitcontrib.runner.resharper.runner.5.0.dll
  3. xunit.dll
  4. xunit.runner.utility.dll

xunit.dll and xunit.runner.utility.dll only require mscorlib, system.dll, system.web.dll and system.xml.dll.

One thing to check is to see if the file is marked as being downloaded from the web - if it is, then I think .net doesn't give them full trust, so that could be stopping things. Right click on each file separately, display properties and see if there's an "Unblock" button, if so, click it, restart Visual Studio and try again.

So, with that out of the way, some more questions:

  1. sfun28, is your VS2010 64 bit too?
  2. Are your applications "any cpu", 32 bit or 64 bit? (ReSharper appears to have support for running tests to match the cpu choice and .net version, and xunit and xunitcontrib are both "any cpu", so this scenario should work) 
  3. You could try logging assembly binding errors (I find this very useful and generally have it turned on for my dev machines anyway) - http://msdn.microsoft.com/en-us/library/e74a18c4.aspx

Let me know if anything works!

Cheers
Matt

Jan 8, 2010 at 10:19 AM

Thanks Matt, unblocking everything has worked for me,

 

Kevin

Jan 8, 2010 at 2:52 PM

same!  bizzare....I've never seen that unblock button before.  Thanks, Matt!!