1

Closed

xUnit test runner does not work on VS2012 with Resharper 7.1.3

description

Below shows that the xUnit test runner is indeed installed and loaded

Licensed to: Hailin Shu
Plugins: 1

1. “xUnit.net unit test provider” v1.3.0.27040 by “xunitcontrib Team”

Visual Studio 11.0.61030.0.

But the tests written in xUnit are still not recognized. Why? Is it that the runner does not support VS2012 or else?

My OS is Windows 8.1 Pro English
Closed May 2, 2014 at 9:48 PM by mattellis

comments

imgen wrote Feb 10, 2014 at 5:54 AM

I am using the latest 1.3 version of the xunit resharper support

imgen wrote Feb 10, 2014 at 6:00 AM

I can also run the xunit tests using trial version of TestDriven.net plugin

mattellis wrote Feb 10, 2014 at 9:23 AM

What do you mean by "not work"? Does it show the test icon in the gutter of the editor? Does it try to run them in the Unit Test Sessions window? Do you see any error messages?

And what version of xunit are you using?

imgen wrote Feb 10, 2014 at 2:33 PM

Not working means that no test icon in the gutter of the editor, no items can be found in the Unit Test Sessions window. No error messages. No nothing.

I am using the latest version of xUnit through nuget

mattellis wrote Feb 10, 2014 at 3:05 PM

If that's the latest stable version, you should be fine. If you're using the pre-release 2.0 alphas, then it's not going to work, unfortunately. The 2.0 version is a complete rewrite and requires extensive changes to the plugin to get working. I'm working on it, but it's not available yet.

Unless you're specifically using any of the new features in 2.0, I'd suggest reverting to 1.9 until the 2.0 runner is available.

imgen wrote Feb 11, 2014 at 12:46 AM

I am using the 1.9.2 version so it should work. This is strange.

mattellis wrote Mar 20, 2014 at 12:23 PM

Did you get this working?