Could not load file or assembly 'xunit, Version=1.5.0.1479'

Topics: ReSharper test runner
Dec 12, 2009 at 6:23 PM
Edited Dec 12, 2009 at 6:25 PM

Hi,

when trying to run Unit Tests from R# 5.0 Build 1550 with xunitcontrib 0.3.2 d in VS 2010 I get the following exception from R#:

Could not load file or assembly 'xunit, Version=1.5.0.1479' or one of its dependencies.

The project references Xunit 1.5.

Alex

Coordinator
Dec 14, 2009 at 9:15 PM

Did you copy the xunit.dll to the plugins/xunitcontrib directory with the two plugin dlls? It needs four dlls in the plugin folder - xunitcontrib.runner.resharper.provider.5.0.dll, xunitcontrib.runner.resharper.runner.5.0.dll, xunit.dll and xunit.runner.utility.dll.

Matt

Dec 15, 2009 at 6:04 AM

Copying the xunit.dll to the plugins folder did solve the exception but tests do not run. They've a grey circle icon in R# unit test sessions window.

Alex

Oct 14, 2010 at 10:50 AM

I'm having the exact same problem (They've a grey circle icon in R# unit test sessions window). Any ideas? The progress bar goes very quickly to green, but none of the tests get run.

Nov 1, 2010 at 9:03 AM

I have the same problem...

"I'm having the exact same problem (They've a grey circle icon in R# unit test sessions window). Any ideas? The progress bar goes very quickly to green, but none of the tests get run."

 

Nov 1, 2010 at 2:09 PM
Have you attempted to replace the xunit.dll that's shipped with the R# runner? If so, do NOT do this.
Nov 1, 2010 at 2:52 PM

Hi

i have follow the install so...

my project refer to 1.6.1.1521

in C:\Program Files\JetBrains\ReSharper\v5.1\Bin\plugins\xunitcontrib.runner.resharper.5.0 there are 1.5.0.1479

is correct?

thx

 

Coordinator
Nov 2, 2010 at 10:52 PM

No. For ReSharper 5.1, you need to download the package for 5.1 - http://xunitcontrib.codeplex.com/releases/view/47298. I'm afraid I'm very behind on re-packaging this as part of the main release, but this version should work just fine.

Nov 3, 2010 at 9:14 AM
mattellis wrote:

No. For ReSharper 5.1, you need to download the package for 5.1 - http://xunitcontrib.codeplex.com/releases/view/47298. I'm afraid I'm very behind on re-packaging this as part of the main release, but this version should work just fine.

Ok now xUnit run ...and work fine :D

 

Thanks