Cannot complete test using xUnit Subspec and Resharper 5.0

Topics: ReSharper test runner
Feb 23, 2011 at 7:38 PM
Edited Feb 23, 2011 at 9:57 PM

Hello.

I'm using VS2010 and Resharper 5.0.  Installed the latest release of xunitcontrib for resharper exactly as instructed (ver 5.0).  I have verfied the plug-in is installed and that xUnit is selected in the Resharper options for Unit testing providers.  When I run the test the class with the test and the method I am testing has a red line thru it.

One thing though, I referenced the 1.7 xunit.dll and the specificationsexamples.dll (made by building the samples project and then adding the reference).  I am able to run a test in the sample SubSpec project.

What am I doing wrong?

I would greatly appreciate the help--I've been fighting this thing all day.

R

Feb 23, 2011 at 10:55 PM

Ok.  I overwrote the xunit.dll and SpecificationExample.dll that I was originally using and now it works. 

The problem I experienced initially may have been a result of the 1.7 version runner that was being pointed to in my PATH variable.  I removed it and decided to overwrite the dlls I was using originally to ensure I was using the right ones (had pasted different xunit dlls several times).

This seemed to do it.  It now works.

R

Coordinator
Feb 24, 2011 at 11:58 AM

Well, glad it's working!