R#5.1 EAP compatibility issues

Topics: ReSharper test runner
May 28, 2010 at 7:16 AM
Edited May 28, 2010 at 7:24 AM
I tried to use xUnit R# runner with R# 5.1. EAP version, but it throws an exception when I try to run any test. Is support for 5.1 EAP planned?
Jun 5, 2010 at 9:15 PM
Same here. Please add support for 5,1 EAP if possible. Thanks!
Coordinator
Jun 7, 2010 at 9:46 AM
I've been mopping up after 5.0 went RTM - I've got a release ready that I just need to package up and update the website. Current plan is to get that done early this week, then I'll get a 5.1 build sorted.
Jun 16, 2010 at 4:23 PM

Hi,

Any schedule for the latest EAP of reshaper, the tests won't do any asserts unfortunately.

Regards,

Coordinator
Jun 16, 2010 at 10:31 PM

The 0.4.1 release targets 5.1.1709.

It looks JetBrains released 1710 today - let me know if 0.4.1 doesn't work with it.

Jun 17, 2010 at 4:56 AM
Hi Mattellis, Inded with 1710 it does not work. And unfortunately is not a simple compile issue, I've took the latest xunitcontrib code and compiled it with the latest reshaper dll's with no luck. The test's simply stay gray and don't run. Regards,
Jun 17, 2010 at 6:36 PM

Hi,

Looks like the issue is fixed with todays release, r1711

Great,