R# 5 Final support

Topics: ReSharper test runner
Apr 15, 2010 at 8:06 PM

Hello,

Any timeframe for a final version of xunit contrib that works with R# 5 RTM?

Cheers,
Dave

Coordinator
Apr 16, 2010 at 10:57 PM

The current 0.3.2 (pre-)release works well with the RTM of R# 5. I'm just doing some polishing to get a full, proper release together (with a few updates for 4.5 and better dotCover support), but this should work just fine until then.

Cheers
Matt

Apr 21, 2010 at 11:28 PM

Thanks for the info.

Just a quick note in case anyone else stumbles upon this post looking for problems with getting xUnitContrib working on VS 2010 in .NET 4.0, you need to unblock the .dlls before you copy them into the ReSharper bin\plugins\xunitcontrib.runner.resharper.5.0 folder. I had troubles unblocking them in the program files folder and had to copy them out and then back in.

Cheers,
Dave

Apr 22, 2010 at 10:35 PM
Edited Apr 22, 2010 at 10:57 PM

I am running VS 2010 with R# 5.0 and while it recognizes the tests, it does not actually run them (they stay gray dots). I made sure to unblock the zip when downloaded and placed the files in the 5.0\bin\plugins\xunitcontrib.runner.resharper.5.0 folder.

I am using the most recent drop of xunitcontrib.

Any ideas what might be causing this?

 

UPDATE : I first ran under .NET 3.5. When I run under .NET 4.0 things work as expected. Any idea how to make R# recognize the target framework?

Apr 22, 2010 at 10:50 PM

I'm having trouble getting R# to recognize the tests.  Does this mean I have misplaced my external annotations file?  Where do I need to put it? Can I put it in my AppData folder instead of Program Files?  The instructions say to put it in 'External Annotations' (note the space), but in my Program Files folder, there is no space: 'ExternalAnnotations'.

Apr 22, 2010 at 11:01 PM

Place the xunit.xml file (from the annotations folder) into the ExternalAnnotations folder in Program Files. R# is picking up my tests, just not running them because I am targeting 3.5.

 

Apr 23, 2010 at 12:52 AM

I pulled down the source and rebuilt it on my machine. Works now targeting 3.5 but I am not sure why that would matter.

May 4, 2010 at 7:33 AM

I also pulled down the latest sources and compiled against latest xunit trunk and resharper 5.0 final edition. Works like a charm!

 

Daniel

May 23, 2010 at 3:36 PM

I had the same issue with VS 2008/ R# 5. I downloaded the source code, compiled, then copied the compiled xunitcontrib.runner.resharper.5.0 files to the ReSharper\bin\Plugins folder. And now I can execute xUnit tests.

Coordinator
Jun 14, 2010 at 10:58 PM

Just to let you know - the 0.4 release fully supports ReSharper 5.0 RTM (as did the 0.3.3 release, but 0.4 is now the default download)