Tests run in a temporary location instead of the default output

Topics: ReSharper test runner
Mar 1, 2010 at 9:40 AM

I was using xUnit 1.1 with Resharper 4.5 so far. Today I decided to upgrade to xUnit 1.5 with the same Resharper version. I followed the instructions to integrate the two of them.

Previously unit tests used to run in the default output folder of my project (bin\debug\...). Now they run in a temporary location ('C:\Users\<user>\AppData\Local\Temp\ba7ba69e-64be-46be-ad18-6b929f75.....).

Resharper>Options>Unit Testing>Shadow-copy was and still is not checked.

Any ideas?

Coordinator
Mar 1, 2010 at 10:32 PM

Ah. That would be because I'm not looking at the ReSharper setting, and it's always set to shadow copy. I'll add a work item to get it fixed - it should be an easy fix.

Matt

Coordinator
Mar 1, 2010 at 10:42 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Mar 2, 2010 at 12:31 AM

You can probably just tell xUnit.net not to shadow copy, because I suspect that R# is already shadow copying everything before it hands it off to you, when that check box is checked. Should be easy to verify.